HSE MY18 InControl Touch Pro Screen Freezing and then black / dead

Faults and Technical chat for the Discovery 5
Post Reply
Quokka
Posts: 1
Joined: Fri Aug 17, 2018 6:09 am

HSE MY18 InControl Touch Pro Screen Freezing and then black / dead

Post by Quokka » Fri Aug 17, 2018 6:29 am

Hi,

My April 2018 build MY18 HSE has the InControl Touch Pro screen that is used to control all sorts of things (as you all know).

The other day I reversed out of my garage / driveway, and as I drove forward, the usual transfer of screen image from rear camera to usual touch screen menu failed to occur. The last image from the rear camera when it should have transitioned remained frozen on the screen. No touching etc seemed to help.

So I pulled over and turned the car off. Waited a minute and restarted. Screen was totally black / dead and unresponsive.

I rang the dealership service department where I bought the vehicle, and in about a minute after giving my car details, they advised me:
Turn the vehicle off; get out of the car; lock the vehicle; and leave it for 20 minutes. Then unlock it and restart.

Not the most ideal solution if raining and in the middle of nowhere! However, this actually worked, and the screen has since been working normally the last couple of days.

Just thought that I would share in case this happens to someone else.

Car is only 2 months old and has only travelled about 2,800 kms.

I also have the screen in front of the driver that is electronic = no gauges. I have sent the dealership an email asking about what I experienced above, as well as my concern if the same thing happens to the driver screen? No speedo = unroadworthy car!

Thanks for reading my long post, but I am also wondering if anyone else has experienced this with their MY2018 HSE ?

regards,

Quokka


Post Reply

Return to “Faults & Technical”