Suspension fault

Faults and Technical chat for the Discovery 5
Post Reply
Hrex
Posts: 11
Joined: Wed Apr 19, 2017 10:50 pm

Suspension fault

Post by Hrex » Tue Mar 13, 2018 3:12 pm

I feel like the rear suspension on my 3.0D is not performing properly (specially rear left). When I for example go over a speed bump It makes a squeaking noise, like I have á faulty shock absorber.

Has anyone experienced something similar?

Six months ago I received a suspension fault error, but was told it was just a software issue.


Craigp
Posts: 208
Joined: Mon Feb 20, 2017 2:34 pm

Re: Suspension fault

Post by Craigp » Tue Mar 13, 2018 7:28 pm

I think there is recall out for suspension (software update ) check topex.
3litre SE. Monticello Red. Electric deployable tow bar.


Fritzz
Posts: 8
Joined: Thu Mar 30, 2017 6:43 am

Re: Suspension fault

Post by Fritzz » Thu Mar 29, 2018 1:46 am

I've had mine since August and the rear suspension just started to squeak as you mentioned. It's most noticeable at relatively slow speeds on bouncy roads or when going over speed bumps. Hard for me to tell which side it is. Any resolution on yours?


Hrex
Posts: 11
Joined: Wed Apr 19, 2017 10:50 pm

Re: Suspension fault

Post by Hrex » Thu Mar 29, 2018 10:44 pm

...sounds exactly like the problem I have. I’m having my car serviced in a months time. Hopefully they will figure out whats going on then.

My car was called in for a suspension fault software update - but it didn’t fix the problem.


Fritzz
Posts: 8
Joined: Thu Mar 30, 2017 6:43 am

Re: Suspension fault

Post by Fritzz » Thu Apr 05, 2018 3:40 am

I took mine to the dealer yesterday. I was informed today that there is a TSB (technical service bulletin) related to squeaks in the rear suspension. The dealer said repair parts were on back order ( here in the USA) and they are researching timing. Not sure what specifically needs replacing but I’ll ask for details. At least they are aware of the problem.


Hrex
Posts: 11
Joined: Wed Apr 19, 2017 10:50 pm

Re: Suspension fault

Post by Hrex » Mon Jul 16, 2018 12:41 am

My dealership recognised the problem. I was told that a suspension bracket was loose.On the invoice this was noted as a “suspension reinforcement”.

It at least fixed the suspension problem and I was told without further damage.


Post Reply

Return to “Faults & Technical”