Climate control issue

Faults and Technical chat for the Discovery 5
penners
Posts: 33
Joined: Thu Jan 05, 2017 2:09 pm

Climate control issue

Post by penners » Sat Apr 08, 2017 5:07 pm

So with us finally having some sunshine got back into car this afternoon after it had been parked for 3-4 hours and zircon not working properly - seemed ok on passenger side, but drivers vents were actually pumping out heated air, rather than simply non-airconditioned!!!

By the time got chance to ring the dealer service department closed but sales rep has taken details and hopefully we'll get it sorted Monday / Tuesday next week as we're away from Good Friday for a week :shock:

Anyone experienced anything similar?


penners
Posts: 33
Joined: Thu Jan 05, 2017 2:09 pm

Re: Climate control issue

Post by penners » Tue Apr 11, 2017 8:43 pm

Update:

Went in to the dealers today - diagnostics showed a fault code related to the computer's control of how the central aircon unit controls the motorised vents that distribute the air to various parts of the cabin; easily sorted with a software download.

Fingers crossed for some more sunshine in the UK to check it's all sorted for sure :lol:


Lee Jackson
Posts: 81
Joined: Fri Dec 02, 2016 1:03 pm

Re: Climate control issue

Post by Lee Jackson » Tue Apr 11, 2017 9:26 pm

Penners I am curious,

If it was that easy too fix couldn't the car have downloaded the software it needed or alert you to the fact an update was available.


Mikep
Posts: 23
Joined: Wed Jan 25, 2017 9:56 pm

Re: Climate control issue

Post by Mikep » Sat Apr 29, 2017 5:24 pm

My car has now developed this fault. Very annoying as I was beginning to think I'd got away with having no faults 🙁

Was it a quick fix with the dealer?


Seaview36
Posts: 16
Joined: Mon Jan 30, 2017 9:05 am

Re: Climate control issue

Post by Seaview36 » Thu May 04, 2017 1:17 pm

Hi All, my 3.0l HSE Lux developed the exact same fault a couple of weeks ago. We got the handbook out and fiddled with the settings to no avail. On a warm day, the last thing you want is warm air being pumped out. Only the drivers side misbehaved, which was odd. We turned the vents off for a few day, as the car was booked in for a dash cam to be fitted, but then found it had gone back to normal........ Very strange, but interesting that other cars have been effected. Possibly it went back to normal when the weather turned cool again, so will wait and see if plays up again. The good thing about the Forum is you can see a pattern if a number of people report with the same problem.


jukn
Posts: 26
Joined: Sun May 14, 2017 4:36 pm

Re: Climate control issue

Post by jukn » Sun May 14, 2017 4:41 pm

I have had the same problem. Only the driver side pumping out red hot air. Reported it and waiting for a response. Yesterday tried it again and it was the same, today for no apparent reason its working? This is only one of a number of faults i have experienced so far
3.0 TD6 HSE Kaikoura Stone, Black Design Pack with 20" wheels style 5011, Capability plus pack, Electric tilt/slide Sunroof with power blinds, Privacy glass, Intelligent seat fold, Fixed side steps, Half height luggage divider


Manu
Posts: 2
Joined: Sat Sep 09, 2017 3:11 pm

Re: Climate control issue

Post by Manu » Sat Sep 09, 2017 4:01 pm

I have had the same problem here in France. Hot air coming out of the right side (passenger side here) on 3 different occasions. Problem goes away after randomly touching other AC related buttons. Car presently with the dealer to look into the problem...


Hrex
Posts: 5
Joined: Wed Apr 19, 2017 10:50 pm

Re: Climate control issue

Post by Hrex » Wed Sep 13, 2017 12:58 am

Same problem. I have a HSE LUX 3.0D. I'm told by the dealership its a known problem...

However I also feel that the AC is not blowing out enough air, unless I set it to max (which is borderline unberable).


Craigp
Posts: 94
Joined: Mon Feb 20, 2017 2:34 pm

Re: Climate control issue

Post by Craigp » Wed Sep 13, 2017 9:28 am

I don't have the problem of the hot blowing but the whole system is poor. Especially in the back. I ended getting a electric fan off eBay to keep the dog cool. It's a joke.


Dogmartin
Posts: 3
Joined: Tue Sep 12, 2017 9:52 am

Re: Climate control issue

Post by Dogmartin » Wed Sep 13, 2017 10:10 am

I have the same issue with the poor AC performance .Especially on the back seats of my First edition.
The dealer did not find anything wrong there in Czech Republic
Do you have any experience with this or any solution .


Post Reply

Return to “Faults & Technical”


Who is online

Users browsing this forum: No registered users and 1 guest