Climate control issue

Faults and Technical chat for the Discovery 5
Craigp
Posts: 195
Joined: Mon Feb 20, 2017 2:34 pm

Re: Climate control issue

Post by Craigp » Wed Sep 13, 2017 5:48 pm

I gather their response is "You should have got the enhanced system" apparently that one works!!
3litre SE. Monticello Red. Electric deployable tow bar.


Hrex
Posts: 8
Joined: Wed Apr 19, 2017 10:50 pm

Re: Climate control issue

Post by Hrex » Thu Sep 21, 2017 4:31 pm

Mine was just fixed - I was told by a software update.


Manu
Posts: 5
Joined: Sat Sep 09, 2017 3:11 pm

Re: Climate control issue

Post by Manu » Tue Oct 10, 2017 9:39 am

I had the "hot air" problem in July and "no AC" problem (it was just pumping outside air) in September. Both fixed by the dealer.


MAJ23
Posts: 2
Joined: Sun Nov 26, 2017 6:20 pm

Re: Climate control issue

Post by MAJ23 » Sun Nov 26, 2017 6:27 pm

My Disco 5 HSE went back after 48 hours from picking it up at the dealership when the aircon was blowing out burning hot air instead of cooling the car. They did a software up date and it's been working fine... until last week, where it is now pushing red hot air out of the drivers side (righthand) so it's going back to the dealership for the 7th time in as many months. Other problems include Bluetooth not working. Voice controls not working. Service indicator coming on after 4500 miles. USB chargers not working. Entertainment screen keeps freezing and not coming on.
LR 5 HSE, Corris Grey, Black Pack, Side Steps, Privacy Glass, Electric Tow Bar.


Parky76
Posts: 3
Joined: Tue Nov 28, 2017 2:38 am

Re: Climate control issue

Post by Parky76 » Tue Nov 28, 2017 2:40 am

My $0.2 worth... Had the same problem with hot air on the driver's side... Took it to the local Land Rover Service place (Solitaire Automotive in Adelaide, South Australia) and they were great: turned out to be a software fix and was in and out in under an hour.


MAJ23
Posts: 2
Joined: Sun Nov 26, 2017 6:20 pm

Re: Climate control issue

Post by MAJ23 » Sun Jan 14, 2018 5:51 pm

My LR5 has been back to the dealer over 10 times now. They have have software updates, changed valves and the problem still exists. The dealer keeps saying that it's an isolated to my vehicle and that Landrover haven't had this problem with any other new Discovery 5's.
LR 5 HSE, Corris Grey, Black Pack, Side Steps, Privacy Glass, Electric Tow Bar.


BeachDisco
Posts: 8
Joined: Tue Jun 27, 2017 4:55 am

Re: Climate control issue

Post by BeachDisco » Fri Feb 16, 2018 8:52 am

We have this exact issue on our HSE (hot air coming out front/driver vents a cold coming out back when all set to low and auto). Went in 3 weeks ago and tech said it was software. They updated, but it was back today. I put a laser thermometer on the vents and saw 105F in the front and 55F in the back. I got great video of the issue and took it back to the dealer, while it was still happening. It sounds like this is systemic. Albeit intermittent. I live in California so AC is still used a lot this time of year.


AndyT
Posts: 6
Joined: Mon Mar 12, 2018 4:24 pm

Re: Climate control issue

Post by AndyT » Wed Apr 18, 2018 4:29 pm

I drove 260 miles today on the warmest day of the year in the UK and guess what? ... the drivers side vents pumped out scalding hot air, no matter what the temp was set to. I'm a bit more worried about what's going on behind the vents as the dash area above the right hand vent is so hot it will burn skin. Waiting for the dealers response.

2017 First Edition D5


jimbg
Posts: 168
Joined: Fri May 19, 2017 8:30 am

Re: Climate control issue

Post by jimbg » Wed Apr 18, 2018 4:33 pm

That is known problem and a fix is available, I suggest that you register on Topix and you can see the titles and basic description of recalls and technical bulletins for free.

It helps to know what is outstanding on your car and others such as yours.


AndyT
Posts: 6
Joined: Mon Mar 12, 2018 4:24 pm

Re: Climate control issue

Post by AndyT » Wed Apr 18, 2018 4:54 pm

Thanks Jim, I found it on TOPix. For others that need to know, I believe it is Campaign H100v2 - "Climate control blowing cold air on one side".


Post Reply

Return to “Faults & Technical”