2016 Discovery Landmark Heater

Faults and Technical chat for the Discovery 5
Post Reply
Deejaydee
Posts: 1
Joined: Thu Dec 15, 2016 2:46 pm

2016 Discovery Landmark Heater

Post by Deejaydee » Thu Dec 15, 2016 2:56 pm

I recently bought a brand new Disco Landmark, 2016, which I love, BUT I'm not sure the heating is working properly and I'm wondering if anyone else has the same issue.

If I set it on 28, manually not climate control or automatic, it takes about 10 minutes before it blows any warmth, stays warm (not hot) for about 10 minutes, then blows cold. The only time it blows constant heat is on the HI setting which is too much after a while - then if I reduce it to 28 it blows cold.

Is this normal or just my car?

Dealer says they recalibrated blower motor and did software update and tested it and it's just how they are. But none of the courtesy cars they've loaned me have gone from warm to cold. And they heat up a lot quicker than mine too. I got JLR involved as it's been in twice now, they're just liaising between me and the dealer.


larratt
Posts: 1
Joined: Wed Sep 28, 2016 8:15 pm

Re: 2016 Discovery Landmark Heater

Post by larratt » Sat May 20, 2017 9:01 pm

My2012 did the same I found that I had it set to 28 a lot of the time and the only way to get it hot was turn the blower to max
My 2015 is much better I have not turned it up past 22 yet but we shall see when the weather drops off again


Sirrah4941
Posts: 7
Joined: Fri Apr 21, 2017 9:13 am

Re: 2016 Discovery Landmark Heater

Post by Sirrah4941 » Mon May 22, 2017 9:36 pm

I've got a 16 plate HSE in black and mine is similar- doesn't seem warm until on high then it's baking but turning it down doesn't throw out heat. I had a courtesy car recent and that heating was much better! I would suggest giving it to the dealer and getting them to test it.


Post Reply

Return to “Faults & Technical”


Who is online

Users browsing this forum: No registered users and 1 guest